summaryrefslogtreecommitdiffstats
path: root/crates/core/tedge_core/Cargo.toml
diff options
context:
space:
mode:
authorMarcel Müller <m.mueller@ifm.com>2022-05-05 10:03:34 +0200
committerMarcel Müller <m.mueller@ifm.com>2022-05-05 10:55:46 +0200
commit501a9b89aab29dc9957e3f3b581277168c8da0bf (patch)
treedac8ba90d55e9b48d791ce5c634931945b2394e1 /crates/core/tedge_core/Cargo.toml
parent4b25ee200574928a3a08d1e8a0a69021988fc9c2 (diff)
Add micro benchmark
Signed-off-by: Marcel Müller <m.mueller@ifm.com>
Diffstat (limited to 'crates/core/tedge_core/Cargo.toml')
-rw-r--r--crates/core/tedge_core/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/crates/core/tedge_core/Cargo.toml b/crates/core/tedge_core/Cargo.toml
index aec575fd..38264d39 100644
--- a/crates/core/tedge_core/Cargo.toml
+++ b/crates/core/tedge_core/Cargo.toml
@@ -20,6 +20,7 @@ tedge_api = { path = "../tedge_api" }
[dev-dependencies]
async-trait = "0.1"
+criterion = { version = "0.3.5", features = ["async_tokio", "html_reports"] }
env_logger = "0.9"
futures = "0.3"
static_assertions = "1.1.0"
@@ -28,3 +29,6 @@ tokio = { version = "1.16.1", features = ["full"] }
tracing = { version = "0.1", default-features = false }
tracing-subscriber = { version = "0.3", default-features = false, features = ["env-filter", "fmt"] }
+[[bench]]
+name = "simple_throughput"
+harness = false