summaryrefslogtreecommitdiffstats
path: root/crates/common/tedge_utils/Cargo.toml
diff options
context:
space:
mode:
authorLukasz Woznicki <75632179+makr11st@users.noreply.github.com>2021-11-24 20:54:56 +0000
committerGitHub <noreply@github.com>2021-11-24 20:54:56 +0000
commita4ffeccf60090e4456755bc53a6e3b8c8038e855 (patch)
tree9583f187114913a92866571920dd3bb205bd50a3 /crates/common/tedge_utils/Cargo.toml
parent8217e80670e76dbf9168780f5e0545355a39f8f3 (diff)
Restructure directories of the workspace (#559)
* Restructure directories of the workspace * Rename c8y_translator_lib to c8y_translator * Update comment on how to get dummy plugin path Signed-off-by: Lukasz Woznicki <lukasz.woznicki@softwareag.com>
Diffstat (limited to 'crates/common/tedge_utils/Cargo.toml')
-rw-r--r--crates/common/tedge_utils/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/crates/common/tedge_utils/Cargo.toml b/crates/common/tedge_utils/Cargo.toml
new file mode 100644
index 00000000..861fff3c
--- /dev/null
+++ b/crates/common/tedge_utils/Cargo.toml
@@ -0,0 +1,26 @@
+[package]
+name = "tedge_utils"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+license = "Apache-2.0"
+description = "tedge_utils provide utilities for thin-edge.io components"
+
+[features]
+# No features on by default
+default = []
+logging = ["tracing", "tracing-subscriber"]
+
+[dependencies]
+anyhow = "1.0"
+futures = "0.3"
+tempfile = "3.2"
+thiserror = "1.0"
+tokio = { version = "1.12", default_features = false, features = [ "fs", "io-util", "macros", "rt-multi-thread","signal"] }
+tracing = { version = "0.1", features = [], optional = true }
+tracing-subscriber = { version = "0.2", optional = true }
+
+[dev-dependencies]
+assert_matches = "1.5"
+
+