summaryrefslogtreecommitdiffstats
path: root/crates/common/flockfile/Cargo.toml
diff options
context:
space:
mode:
authorLukasz Woznicki <75632179+makr11st@users.noreply.github.com>2021-11-24 20:54:56 +0000
committerGitHub <noreply@github.com>2021-11-24 20:54:56 +0000
commita4ffeccf60090e4456755bc53a6e3b8c8038e855 (patch)
tree9583f187114913a92866571920dd3bb205bd50a3 /crates/common/flockfile/Cargo.toml
parent8217e80670e76dbf9168780f5e0545355a39f8f3 (diff)
Restructure directories of the workspace (#559)
* Restructure directories of the workspace * Rename c8y_translator_lib to c8y_translator * Update comment on how to get dummy plugin path Signed-off-by: Lukasz Woznicki <lukasz.woznicki@softwareag.com>
Diffstat (limited to 'crates/common/flockfile/Cargo.toml')
-rw-r--r--crates/common/flockfile/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/crates/common/flockfile/Cargo.toml b/crates/common/flockfile/Cargo.toml
new file mode 100644
index 00000000..91a4e267
--- /dev/null
+++ b/crates/common/flockfile/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "flockfile"
+version = "0.4.3"
+authors = ["thin-edge.io team <info@thin-edge.io>"]
+edition = "2018"
+
+[dependencies]
+thiserror = "1.0"
+
+[target.'cfg(unix)'.dependencies]
+nix = "0.23"
+tracing = { version = "0.1", features = ["log"] }
+
+[dev-dependencies]
+assert_matches = "1.5"
+tempfile = "3.2"