summaryrefslogtreecommitdiffstats
path: root/crates/common/download/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <matthias.beyer@ifm.com>2022-07-14 09:09:24 +0200
committerMatthias Beyer <matthias.beyer@ifm.com>2022-07-14 09:09:24 +0200
commit0befb2c8a7c25f89f9237a32db0d0807d1e989bf (patch)
treef72cd747f8ea62bc80c1c1d547981e9e68b24a9b /crates/common/download/Cargo.toml
parentcaa5d19df8bd51890ed4710d2fab58f43a585cdd (diff)
download: Remove unused dependency "tedge_utils"
This patch removes the "tedge_utils" dependency, which is not used in the crate. Because "tedge_utils" pulled in "tokio" with the "fs" feature enabled, which is not enabled by default, we also need to enable "fs" on tokio now, which is also done in this patch. Signed-off-by: Matthias Beyer <matthias.beyer@ifm.com>
Diffstat (limited to 'crates/common/download/Cargo.toml')
-rw-r--r--crates/common/download/Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/crates/common/download/Cargo.toml b/crates/common/download/Cargo.toml
index b569e113..e4977cb5 100644
--- a/crates/common/download/Cargo.toml
+++ b/crates/common/download/Cargo.toml
@@ -14,9 +14,8 @@ nix = "0.23"
reqwest = { version = "0.11", default-features = false, features = ["rustls-tls"] }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
-tedge_utils = { path = "../tedge_utils" }
thiserror = "1.0"
-tokio = "1.12"
+tokio = { version = "1.12", features = ["fs"] }
url = "2.2"
[dev-dependencies]