summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPradeepKiruvale <PRADEEPKIRUVALE@gmail.com>2021-01-15 15:18:13 +0530
committerGitHub <noreply@github.com>2021-01-15 15:18:13 +0530
commitcdb341e37c584a9a2fa39b155446559d2068da6f (patch)
treea932135f0a0183ae90304211a1ef2d23edf95bde /Cargo.toml
parent69eb1334386726317086a355cd37bce1314af81b (diff)
[CIT-102] Thin Edge Json to C8y Json translator library (#10)
* [CIT-102] Thin Edge Json to C8y Json translator library * [CIT-102] moved pretty_assertions into dev-dependancies [CIT-102] removed commented code [CIT-102] renamed c8ytype to c8y_type [CIT-102] Changed timestamp to DateTime type from string [CIT-102] Fixed example name typo [CIT-102] rename c8y_type to c8y_msg_type [CIT-102] make MultiValueMeasurement struct to pub [CIT-102] moved JsonError down in the file [CIT-102] Removed e/println! macros [CIT-102] Moved the coversion of struct to enum into the create function [CIT-102] add wild cards to gitignore [CIT-102] Changed datetime stamp to Utc * [CIT-102] Fixed some indentation issue [CIT-102] Fixed json indentation issue [CIT-102] c8yobj to c8y_obj [CIT-102] c8yobj to c8y_object [CIT-102] created a reuseable insert function [CIT-102] cargo fmt [CIT-102] Simplified the assert_eq [CIT-102] c8yjson to c8y_json [CIT-102] single_value_thinedge to single_value_thin_edge [CIT-102] multi_value_thin_obj to multi_value_thin_edge_object [CIT-102] create_value_obj to create_value_object [CIT-102] json::from to into [CIT-102] mutlivale to multi_value [CIT-102] single_value to single_values [CIT-102] initialize vector with vec! instead of new [CIT-102] thinedge to thin_edge [CIT-102] c8yjson to c8y_json [CIT-102] re-ordered parameters in create_multi_val [CIT-102] Refactored from_json function [CIT-102] avoid clone * [CIT-102] translate timestamp and type * [CIT-102] Fixed the formating and names in example * [CIT-102] Added a test to test timestamp and type translation * [CIT-102] Removed dead code in library * [CIT-102] time and type as thin edge reserved words [cit-102] changed the value to f64 from json::Number [CIT-102] Removed dead code * [CIT-102] renamed JsonError to ThinEdgeJsonError [CIT-102] changed error handling to shorthand notation [CIT-103] removed simple insert_object function [CIT-102] rename create_c8y_obj to new and made it a method of Cumulocity structure [CIT-102] translate_multi value as method of CumulocityJson structure [CIT-102] Moved single_val translation as part of C8Y structure [CIT-103] move all c8y struct methods to one place [CIT-102] remaned thinedge to thin_edge [CIT-103] move all the create_* functions as methods of ThinEdgeValue enum * [CIT-102] Moved the insert_object function into the Cumulocity structure [CIT-102] Moved create value object inside Cumulocity Struct [CIT-102] Move the into_cumulocity_json method into CumulocityJson structure [CIT-102] Refactored translate functions [CIT-102] Renamed type of message to ThinEdgeMeasurement [CIT-102] Moved create methods to resepective structs * [CIT-102] Check timestamp for iso8601 complaint * [CIT-102] Fixed example, removed type from thin-edge message [CIT-102] Added a function to deserialize the c8yjson [CIT-102] Expose only CumulocityJson API [CIT-102] Added test for deserialization check [CIT-102] Fixed pretty printing, with extra white spaces * [CIT-102] Moved time-stamp into ThinEdgeJson struct * [CIT-102] Remove unwrap for timestamp validation and return proper error * [CIT-102] Removed unwrap and returning error * [CIT-102] check time key before checking value * [CIT-102] Check for keywords type and time * [CIT-102] Fixed the invalid json in example * [CIT-102] Implemented test cases to check thin-edge-json validity * [CIT-102] Fixed doc test and fixed comments * [CIT-102] Renamed create_* functions as new * [CIT-102] Fixed thinedge hierarchy test * [CIT-102] Added and updated the comments * [CIT-102] Added proptest * [CIT-102] Fixed minor test issues * [CIT-102] move proptest inside test module, proptest crate inside the dev-dependancy Co-authored-by: Pradeep K J <pradeekumar.kj@softwareag.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a6e8988b..125193b6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,6 +4,7 @@ members = [
"mqtt/mqtt_client",
"tedge",
"tests/testlib",
+ "translator/c8y_json_translator",
]
[profile.release]