summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLukasz Woznicki <75632179+makr11st@users.noreply.github.com>2021-07-05 10:50:18 +0100
committerGitHub <noreply@github.com>2021-07-05 10:50:18 +0100
commit8d925a9cfafd2e6350cffc987cb3497c0cf991e1 (patch)
tree5a3098c3c76af67f249034da5454a28d23a34fb5 /Cargo.toml
parentcef3023c94a5adf7cdc1ff3be6b62e74f7ac8fe4 (diff)
Add binary size optimization to decrease size of the produced binaries (#316)
Signed-off-by: Lukasz Woznicki <lukasz.woznicki@softwareag.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ad2b4a1c..cf0bc978 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,4 +16,7 @@ members = [
]
[profile.release]
+codegen-units = 1
lto = true
+opt-level = "z"
+panic = 'abort'