summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDidier Wenzek <didier.wenzek@acidalie.com>2021-07-30 16:32:13 +0100
committerGitHub <noreply@github.com>2021-07-30 17:32:13 +0200
commit3e606a8e2e56c64e63321648c5f55e11bd00abb7 (patch)
tree353042a82949e7f4beb08d6ea5559613e09a58bd /Cargo.toml
parentb858b8d0e39ad546f53f540dc87eaa684b060cec (diff)
[CIT-500] thin edge json extension to handle software management messages (#360)
* [CIT-500] Add the crate `sm/json_sm` * [CIT-500] Start with code from PR #354 * [CIT-500] Add helper method for software list request and response * [CIT-500] Move all the messages into the `messages` module * [CIT-500] Add help method to create software update requests * [CIT-500] Using a software list response * [CIT-500] Fix version in Cargo.toml * [CIT-500] Make optional the current list of software * [CIT-500] Report software update errors * [CIT-500] Add getter for operation status * [CIT-500] Retrieve the list of modules of a software list response * [CIT-500] Cargo fmt Co-authored-by: Wenzek <diw@softwareag.com> Co-authored-by: Rina Fujino <18257209+rina23q@users.noreply.github.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index deb68bb4..1c60cac1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,8 @@ members = [
"mapper/cumulocity/c8y_translator_lib",
"mapper/tedge_mapper",
"mapper/thin_edge_json",
- "sm/plugins/tedge_apt_plugin"
+ "sm/plugins/tedge_apt_plugin",
+ "sm/json_sm"
]
[profile.release]