summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorPradeepKiruvale <PRADEEPKIRUVALE@gmail.com>2021-06-17 18:22:36 +0530
committerGitHub <noreply@github.com>2021-06-17 18:22:36 +0530
commit197eae5e5c0fea07b6a7c77a89b86bc98bdefa59 (patch)
tree71526cf3c38e03f563c2c7f1a4c354078ffb1b30 /Cargo.toml
parent6529965a3cc2b2c69a899df1709826c117c5f555 (diff)
[cit-415] Refactor TEJ/C8Y Serializer code (#292)
* Use String for serialization * Add a JsonWriter abstraction * [CIT-415] add unit tests * [CIT-415] addressed review comments * [CIT-415] updated test cases * [CIT-415] Add key type * Use serde_json::to_writer for serialization * use serde_json for serializing * fix azure_converter tests * [CIT-415] Add test for key with quote Co-authored-by: Michael Neumann <mneumann@ntecs.de> Co-authored-by: Pradeep K J <Pradeep K J pradeekumar.kj@softwareag.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6373c353..ad2b4a1c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,6 +6,7 @@ members = [
"common/mqtt_client",
"common/clock",
"common/tedge_users",
+ "common/json_writer",
"tedge",
"tedge_config",
"mapper/cumulocity/c8y_translator_lib",