summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLukasz Woznicki <75632179+makr11st@users.noreply.github.com>2021-08-08 21:38:00 +0100
committerGitHub <noreply@github.com>2021-08-08 21:38:00 +0100
commit1040ce0e723ef8f6650a1ad0c454a68a707204ed (patch)
treef1178def8446c4274ed3ce39aac559b5f12b789e /Cargo.toml
parentc49f7703eff5754d53b3d961194839337f7eda53 (diff)
[CIT-450] Tedge Agent - SM feature (#354)
* Add basic tedge_agent code and service * Add tedge_utils::fs atomically write file * Add short documentation notes for tedge_agent * Make sm-plugins path dynamic for agent * Update dependencies due to cargo audit hyper vuln Signed-off-by: Lukasz Woznicki <lukasz.woznicki@softwareag.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 8 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1c60cac1..31c7531e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,18 +3,21 @@
members = [
"common/batcher",
"common/certificate",
+ "common/clock",
"common/flockfile",
+ "common/json_writer",
"common/mqtt_client",
- "common/clock",
"common/tedge_users",
- "common/json_writer",
- "tedge",
- "tedge_config",
+ "common/tedge_utils",
"mapper/cumulocity/c8y_translator_lib",
"mapper/tedge_mapper",
"mapper/thin_edge_json",
+ "sm/json_sm",
+ "sm/plugin_sm",
+ "sm/tedge_agent",
"sm/plugins/tedge_apt_plugin",
- "sm/json_sm"
+ "tedge_config",
+ "tedge",
]
[profile.release]