summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e1c2a451d..1c673702c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -49,7 +49,9 @@ nom = "5.0.1"
os_info = "1.2.0"
urlencoding = "1.0.0"
open = "1.3.2"
-reqwest = "0.9.24"
+# OpenSSL causes problems when building a MUSL release. Opting to use native SSL implementation
+# see: https://github.com/richfelker/musl-cross-make/issues/65#issuecomment-509790889
+reqwest = { version = "0.9.24", default-features = false, features = ["rustls-tls"] }
[dev-dependencies]
tempfile = "3.1.0"