summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 14 insertions, 14 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ab8e81167..4bdfb0521 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "starship"
-version = "1.18.2"
+version = "1.19.1"
authors = ["Starship Contributors"]
build = "build.rs"
categories = ["command-line-utilities"]
@@ -49,8 +49,8 @@ dirs = "5.0.1"
dunce = "1.0.4"
gethostname = "0.4.3"
# default feature restriction addresses https://github.com/starship/starship/issues/4251
-gix = { version = "0.62.0", default-features = false, features = ["max-performance-safe", "revision"] }
-gix-features = { version = "0.38.1", optional = true }
+gix = { version = "0.63.0", default-features = false, features = ["max-performance-safe", "revision"] }
+gix-features = { version = "0.38.2", optional = true }
indexmap = { version = "2.2.6", features = ["serde"] }
log = { version = "0.4.21", features = ["std"] }
# notify-rust is optional (on by default) because the crate doesn't currently build for darwin with nix
@@ -58,7 +58,7 @@ log = { version = "0.4.21", features = ["std"] }
notify-rust = { version = "4.11.0", optional = true }
nu-ansi-term = "0.50.0"
once_cell = "1.19.0"
-open = "5.1.2"
+open = "5.1.3"
# update os module config and tests when upgrading os_info
os_info = "3.8.2"
path-slash = "0.2.1"
@@ -69,25 +69,25 @@ rand = "0.8.5"
rayon = "1.10.0"
regex = { version = "1.10.4", default-features = false, features = ["perf", "std", "unicode-perl"] }
rust-ini = "0.21.0"
-semver = "1.0.22"
-serde = { version = "1.0.199", features = ["derive"] }
-serde_json = "1.0.116"
+semver = "1.0.23"
+serde = { version = "1.0.203", features = ["derive"] }
+serde_json = "1.0.117"
sha1 = "0.10.6"
-shadow-rs = { version = "0.27.1", default-features = false }
+shadow-rs = { version = "0.28.0", default-features = false }
# battery is optional (on by default) because the crate doesn't currently build for Termux
# see: https://github.com/svartalf/rust-battery/issues/33
starship-battery = { version = "0.8.3", optional = true }
strsim = "0.11.1"
systemstat = "=0.2.3"
terminal_size = "0.3.0"
-toml = { version = "0.8.12", features = ["preserve_order"] }
-toml_edit = "0.22.12"
+toml = { version = "0.8.13", features = ["preserve_order"] }
+toml_edit = "0.22.13"
unicode-segmentation = "1.11.0"
unicode-width = "0.1.12"
urlencoding = "2.1.3"
versions = "6.2.0"
which = "6.0.1"
-yaml-rust2 = "0.8.0"
+yaml-rust2 = "0.8.1"
process_control = { version = "4.1.0", features = ["crossbeam-channel"] }
@@ -96,7 +96,7 @@ home = "0.5.9"
shell-words = "1.1.0"
[dependencies.schemars]
-version = "0.8.17"
+version = "0.8.21"
optional = true
features = ["preserve_order", "indexmap2"]
@@ -117,14 +117,14 @@ features = [
nix = { version = "0.28.0", default-features = false, features = ["feature", "fs", "user"] }
[build-dependencies]
-shadow-rs = { version = "0.27.1", default-features = false }
+shadow-rs = { version = "0.28.0", default-features = false }
dunce = "1.0.4"
[target.'cfg(windows)'.build-dependencies]
winres = "0.1.12"
[dev-dependencies]
-mockall = "0.12"
+mockall = "0.12.1"
tempfile = "3.10.1"
[profile.release]