summaryrefslogtreecommitdiffstats
path: root/crates/starship_module_config_derive/Cargo.toml
diff options
context:
space:
mode:
authorMatan Kushner <hello@matchai.dev>2021-07-02 16:54:52 -0400
committerMatan Kushner <hello@matchai.dev>2021-07-02 16:54:52 -0400
commit8bb76e08eeacdbeb7b51a2aee1c7cc9dbfba2b81 (patch)
treeda1a891376d494c6a5b0f17caf3f50560c07f228 /crates/starship_module_config_derive/Cargo.toml
parenta123df24dcd4b360c71b92a661b8c405dcbcbd62 (diff)
Add binary cachingbinary-caching
Diffstat (limited to 'crates/starship_module_config_derive/Cargo.toml')
-rw-r--r--crates/starship_module_config_derive/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/starship_module_config_derive/Cargo.toml b/crates/starship_module_config_derive/Cargo.toml
new file mode 100644
index 000000000..928eef5f6
--- /dev/null
+++ b/crates/starship_module_config_derive/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "starship_module_config_derive"
+version = "0.2.1"
+edition = "2018"
+authors = ["Matan Kushner <hello@matchai.me>"]
+homepage = "https://starship.rs"
+documentation = "https://starship.rs/guide/"
+repository = "https://github.com/starship/starship"
+readme = "README.md"
+license = "ISC"
+keywords = ["prompt", "shell", "bash", "fish", "zsh"]
+categories = ["command-line-utilities"]
+description = """
+The minimal, blazing-fast, and infinitely customizable prompt for any shell! ☄🌌️
+"""
+include = ["src/**/*", "LICENSE", "README.md"]
+
+[lib]
+name = "starship_module_config_derive"
+proc-macro = true
+
+[dependencies]
+proc-macro2 = "~1"
+quote = "~1"
+syn = "~1"