summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatan Kushner <hello@matchai.me>2019-04-15 20:54:52 -0400
committerGitHub <noreply@github.com>2019-04-15 20:54:52 -0400
commit794ae7b2ad3d79009162fa7f2d4fe24997f7c2d1 (patch)
tree8a60c56f3092c1c21844bd5d842b4b328b67c6ea /Cargo.toml
parentab5490bea691d6c5fbe525a54799c17d4bd76dca (diff)
Add integration tests (#6)
### Changed - Added current_dir param to segments to make them more testable - Moved all existing integration tests to a `tests/` dir ### Added - A whole bunch of new integration tests
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 69dadcbf3..678d927c8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,3 +9,6 @@ clap = "2.32.0"
ansi_term = "0.11.0"
dirs = "1.0.5"
git2 = "0.8.0"
+
+[dev-dependencies]
+tempdir = "0.3.7"