summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Knaack <davidkna@users.noreply.github.com>2020-01-19 17:00:40 +0100
committerMatan Kushner <hello@matchai.me>2020-01-19 11:00:40 -0500
commitd869b3a09870d432a71d63623bb235b5345e680f (patch)
tree8c6598b874a8e0c0beb48488834626350932b8f3 /Cargo.toml
parent6a9eaa90b5cfcb7e1540adbc17f0dde10502cd06 (diff)
refactor: replace reqwest with ureq (#844)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 2 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 640d64da4..e198717a6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -49,9 +49,8 @@ nom = "5.1.0"
os_info = "1.3.0"
urlencoding = "1.0.0"
open = "1.3.2"
-# OpenSSL causes problems when building a MUSL release. Opting to use native SSL implementation
-# see: https://github.com/richfelker/musl-cross-make/issues/65#issuecomment-509790889
-reqwest = { version = "0.10.1", default-features = false, features = ["blocking", "rustls-tls"] }
+ureq = { version = "0.11.3", default-features = false, features = ["tls"] }
+serde_urlencoded = "0.6.1"
unicode-width = "0.1.7"
textwrap = "0.11.0"
term_size = "0.3.1"