summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorThomas O'Donnell <andytom@users.noreply.github.com>2021-01-21 22:59:14 +0100
committerGitHub <noreply@github.com>2021-01-21 22:59:14 +0100
commit5cf1c8a7bdc9cd385d37dd1310b09099a966796d (patch)
tree81f66e27246c6f1c3df9c5b274956d7bf1c6943f /Cargo.toml
parentb5fd517972ffc3d0b2c108b0d3cc4218e10ce648 (diff)
perf(utils): Add timeout to `utils::exec_cmd` (#2171)
* perf(utils): Add timeout to `utils::exec_cmd` This adds a timeout to any command executed using the `utils::exec_cmd`. The initial time limit is hard coded to 500ms but if required we can make this configurable. Have also switched the tests to be a bit more granular on which systems they are ignored. * Terminate the processes if they timeout
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a6c26a345..da3af3a91 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -64,6 +64,7 @@ indexmap = "1.6.1"
notify-rust = { version = "4.2.2", optional = true }
semver = "0.11.0"
which = "4.0.2"
+process_control = { version = "3.0.0", features = ["crossbeam-channel"] }
# Optional/http:
attohttpc = { version = "0.16.1", optional = true, default-features = false, features = ["tls", "form"] }