summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Knaack <davidkna@users.noreply.github.com>2020-12-20 18:24:28 +0100
committerGitHub <noreply@github.com>2020-12-20 18:24:28 +0100
commitca2de56914a245475a5c567b87550bacc869b8bf (patch)
tree1f49763f0e5e11da790f558895c57fa8d613406a /Cargo.toml
parent4f51ef8db1cbdeda7a70eb7df2cbd55bd7d538b3 (diff)
refactor: specify all dependencies up to the patch/x.y.z level (#2002)
* refactor: specify all dependencies up to the patch/x.y.z level * add pest
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1f0481ee2..299b52c4e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33,7 +33,7 @@ ansi_term = "0.12.1"
dirs-next = "2.0.0"
git2 = { version = "0.13.12", default-features = false }
toml = { version = "0.5.7", features = ["preserve_order"] }
-rust-ini = "0.16"
+rust-ini = "0.16.0"
serde_json = "1.0.60"
rayon = "1.5.0"
log = { version = "0.4.11", features = ["std"] }
@@ -44,13 +44,13 @@ path-slash = "0.1.3"
unicode-segmentation = "1.7.1"
gethostname = "0.2.1"
once_cell = "1.5.2"
-chrono = "0.4"
+chrono = "0.4.19"
sys-info = "0.7.0"
byte-unit = "4.0.9"
starship_module_config_derive = { version = "0.1.2", path = "starship_module_config_derive" }
-yaml-rust = "0.4"
-pest = "^2.1"
-pest_derive = "^2.1"
+yaml-rust = "0.4.4"
+pest = "2.1.3"
+pest_derive = "2.1.0"
regex = "1.4.2"
os_info = "3.0.1"
urlencoding = "1.1.1"
@@ -66,11 +66,11 @@ semver = "0.11.0"
# Optional/http:
attohttpc = { version = "0.16.0", optional = true, default-features = false, features = ["tls", "form"] }
-native-tls = { version = "0.2", optional = true }
+native-tls = { version = "0.2.6", optional = true }
shell-words = "1.0.0"
[target.'cfg(windows)'.dependencies]
-winapi = { version = "0.3", features = [
+winapi = { version = "0.3.9", features = [
"winuser",
"securitybaseapi",
"processthreadsapi",