summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRust大闸蟹 <liaoymxsdl@sina.com>2021-01-23 03:14:51 +0800
committerGitHub <noreply@github.com>2021-01-22 20:14:51 +0100
commitbcaf83532117c49e0f51864f59352630be1d0f90 (patch)
treec2b420a064836ff788cc4914700f2b45b1a9ab2e /Cargo.toml
parent5471007db928e5ad5bdaa24df54360451c9b4f18 (diff)
build: Add additional build information to version and bug report (#2124)
* fix https://github.com/starship/starship/issues * cargo fmt * upgrade shadow-rs 0.5.6 * upgrade shadow-rs * update * complet bug_report infomation * cargo fmt * upgrade shadow-rs 0.5.11 * upgrade shadow-rs 0.5.14 * fixed:https://github.com/starship/starship/pull/2124#discussion_r559076634 fixed:https://github.com/starship/starship/pull/2124#discussion_r559076918 * add long_version * upgrade shadow-rs 0.5.19; adaptate clap version() use by shadow-rs clap_version() * fix unit test error * fix test error * upgrade shadow-rs 0.5.22 * upgrade shadow-rs 0.5.23
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d8fac6f1c..a4018b59f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,6 +10,7 @@ readme = "README.md"
license = "ISC"
keywords = ["prompt", "shell", "bash", "fish", "zsh"]
categories = ["command-line-utilities"]
+build = "build.rs"
description = """
The minimal, blazing-fast, and infinitely customizable prompt for any shell! ☄🌌️
"""
@@ -64,6 +65,8 @@ indexmap = "1.6.1"
notify-rust = { version = "4.2.2", optional = true }
semver = "0.11.0"
which = "4.0.2"
+shadow-rs = "0.5.23"
+
process_control = { version = "3.0.0", features = ["crossbeam-channel"] }
# Optional/http:
@@ -83,6 +86,9 @@ winapi = { version = "0.3.9", features = [
[target.'cfg(not(windows))'.dependencies]
nix = "0.19.1"
+[build-dependencies]
+shadow-rs = "0.5.23"
+
[dev-dependencies]
tempfile = "3.2.0"