summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Knaack <davidkna@users.noreply.github.com>2022-08-09 04:33:00 +0200
committerGitHub <noreply@github.com>2022-08-08 22:33:00 -0400
commitac55a01d0ffe907ef7af48c9597c0bca4dbd8c69 (patch)
tree777418ce50e602d21b737ac02d76078c386665d3 /Cargo.toml
parentf614fcdc1f2b7ad2cbfd6865a774775c032001de (diff)
feat(git): replace `git2` with `git-repository` (#3883)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 4 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 24f87b70e..bbd88beca 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,9 +22,8 @@ keywords = ["prompt", "shell", "bash", "fish", "zsh"]
license = "ISC"
readme = "README.md"
repository = "https://github.com/starship/starship"
-# MSRV is specified due to our dependency in git2
# Note: MSRV is only intended as a hint, and only the latest version is officially supported in starship.
-rust-version = "1.60"
+rust-version = "1.59"
description = """
The minimal, blazing-fast, and infinitely customizable prompt for any shell! ☄🌌️
"""
@@ -43,7 +42,7 @@ clap_complete = "3.2.3"
dirs-next = "2.0.0"
dunce = "1.0.2"
gethostname = "0.2.3"
-git2 = { version = "0.14.4", default-features = false }
+git-repository = "0.20.0"
indexmap = { version = "1.9.1", features = ["serde"] }
local_ipaddress = "0.1.3"
log = { version = "0.4.16", features = ["std"] }
@@ -65,7 +64,7 @@ semver = "1.0.13"
serde = { version = "1.0.142", features = ["derive"] }
serde_json = "1.0.83"
sha-1 = "0.10.0"
-shadow-rs = "0.16.1"
+shadow-rs = { version = "0.16.1", default-features = false }
# battery is optional (on by default) because the crate doesn't currently build for Termux
# see: https://github.com/svartalf/rust-battery/issues/33
starship-battery = { version = "0.7.9", optional = true }
@@ -109,7 +108,7 @@ features = [
nix = { version = "0.24.2", default-features = false, features = ["feature", "fs", "user"] }
[build-dependencies]
-shadow-rs = "0.16.1"
+shadow-rs = { version = "0.16.1", default-features = false }
dunce = "1.0.2"
[target.'cfg(windows)'.build-dependencies]