summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authoryuri <1969yuri1969@gmail.com>2019-10-25 03:00:05 +0200
committerMatan Kushner <hello@matchai.me>2019-10-25 10:00:05 +0900
commitb7762a3e9185000b920a8777bd8aa1fb77eacc56 (patch)
tree0c8fd0c2ed888aa6bfadf3c90aa86ddae6a76bda /Cargo.toml
parentedf5176c37f7a309e72dc486f5659d2193d24336 (diff)
fix: Show Java version from OpenJ9 Java runtimes (#507)
This PR tries to improve the version detection across multiple Java VM vendors. The module captures both STDOUT and STDERR outputs of the java -Xinternalversion call. Eclipse OpenJ9, Azul Zulu, SapMachine, Amazon Corretto and GraalVM outputs are unit tested now.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c6b258d41..b54f60ede 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,6 +45,7 @@ sysinfo = "0.9.5"
byte-unit = "3.0.3"
starship_module_config_derive = { version = "0.1.0", path = "starship_module_config_derive" }
yaml-rust = "0.4"
+nom = "5.0.1"
[dev-dependencies]
tempfile = "3.1.0"