summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatan Kushner <hello@matchai.dev>2021-07-04 10:17:47 -0400
committerMatan Kushner <hello@matchai.dev>2021-07-04 10:17:47 -0400
commitad4705b7e92a782b2f3c6457a4771f6b34b34133 (patch)
treeef5dbd3020e7645cae51a801f0570f1a37452c07 /Cargo.toml
parent23539446b0f5c48008ac7cbe6b0fce5af5d1e141 (diff)
Flesh out exec_cmd with cachebinary-caching-refactor
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1a2ad5e66..f5b11c49a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,8 +28,10 @@ http = ["attohttpc"]
# Vendor OpenSSL, use this if you have trouble cross-compiling starship
tls-vendored = ["native-tls/vendored"]
-
[dependencies]
+starship_cache = { version = "0.1.0", path = "crates/starship_cache" }
+starship_module_config_derive = { version = "0.2.1", path = "crates/starship_module_config_derive" }
+
clap = "2.33.3"
ansi_term = "0.12.1"
dirs-next = "2.0.0"
@@ -49,7 +51,6 @@ once_cell = "1.8.0"
chrono = "0.4.19"
sys-info = "0.9.0"
byte-unit = "4.0.12"
-starship_module_config_derive = { version = "0.2.1", path = "starship_module_config_derive" }
yaml-rust = "0.4.5"
pest = "2.1.3"
pest_derive = "2.1.0"
@@ -103,3 +104,6 @@ lto = true
[[bin]]
name = "starship"
path = "src/main.rs"
+
+[workspace]
+members = ["crates/*"]