summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorWilliam Mantly <wmantly@gmail.com>2019-12-12 16:15:31 -0500
committerBrian May <brian@linuxpenguins.xyz>2019-12-13 08:15:31 +1100
commit69d3f7dc64211d3ab91991cc90865dbf9edcba15 (patch)
tree84d44cc4ea82bbc27fcbc70f3ecd0e6f3127d105 /setup.py
parent6ad4473c87511bcafaec3d8d0c69dfcb166b48ed (diff)
Auto sudoers file (#269)
* added sudoers options to command line arguments * added sudoers options to command line arguments * template for sudoers file * Added option for GUI sudo * added support for GUI sudo * script for auto adding sudo file * sudoers auto add works and validates * small change * Clean up for CI * removed code that belongs in another PR * added path for package bins * added sudoers bin * added sudoers-add to setup file * fixed issue with sudoers bash script * auto sudoers now works * added --sudoers-no-modify option * bin now works with ./run * removed debug print * Updated sudoers-add script * Fixed error passing sudoers config to script * more dynamic building of sudoers file * added option to specify sudoers.d file name * fixed indent issue * fixed indent issue * indent issue * clean up * formating * docs * fix for flags * Update usage.rst * removed shell=true * cleared CI errors * cleared CI errors * removed random * cleared linter issue * cleared linter issue * cleared linter issue * updated sudoers-add script * safer temp file * moved bin directory * moved bin directory * removed print * fixed spacing issue * sudoers commands must only containe upper case latters
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d5f3c7e..5d71237 100755
--- a/setup.py
+++ b/setup.py
@@ -52,6 +52,7 @@ setup(
"Programming Language :: Python :: 3.5",
"Topic :: System :: Networking",
],
+ scripts=['bin/sudoers-add'],
entry_points={
'console_scripts': [
'sshuttle = sshuttle.cmdline:main',