summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBrian May <brian@linuxpenguins.xyz>2016-01-17 10:17:44 +1100
committerBrian May <brian@linuxpenguins.xyz>2016-01-17 10:21:21 +1100
commit7f0b5c698b6336f91c9587f2dc10e2439d0f73bd (patch)
treee718e284733246b8ee9e0b592e1effa002b0e90d /setup.py
parentf59508f41b5543159a3ada57ffdb4bd11a805b54 (diff)
Fix installation from wheel
Fix the following error. Looks like we have to have a function to call for the entrypoint. $ pip install dist/sshuttle-0.76.dev8_ngf59508f-py2-none-any.whl Processing ./dist/sshuttle-0.76.dev8_ngf59508f-py2-none-any.whl Installing collected packages: sshuttle Exception: Traceback (most recent call last): File "/tmp/ddd/local/lib/python2.7/site-packages/pip/basecommand.py", line 211, in main status = self.run(options, args) File "/tmp/ddd/local/lib/python2.7/site-packages/pip/commands/install.py", line 311, in run root=options.root_path, File "/tmp/ddd/local/lib/python2.7/site-packages/pip/req/req_set.py", line 646, in install **kwargs File "/tmp/ddd/local/lib/python2.7/site-packages/pip/req/req_install.py", line 803, in install self.move_wheel_files(self.source_dir, root=root) File "/tmp/ddd/local/lib/python2.7/site-packages/pip/req/req_install.py", line 998, in move_wheel_files isolated=self.isolated, File "/tmp/ddd/local/lib/python2.7/site-packages/pip/wheel.py", line 479, in move_wheel_files maker.make_multiple(['%s = %s' % kv for kv in console.items()]) File "/tmp/ddd/local/lib/python2.7/site-packages/pip/_vendor/distlib/scripts.py", line 364, in make_multiple filenames.extend(self.make(specification, options)) File "/tmp/ddd/local/lib/python2.7/site-packages/pip/_vendor/distlib/scripts.py", line 353, in make self._make_script(entry, filenames, options=options) File "/tmp/ddd/local/lib/python2.7/site-packages/pip/_vendor/distlib/scripts.py", line 244, in _make_script script = self._get_script_text(entry).encode('utf-8') File "/tmp/ddd/local/lib/python2.7/site-packages/pip/wheel.py", line 396, in _get_script_text "import_name": entry.suffix.split(".")[0], AttributeError: 'NoneType' object has no attribute 'split'
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f67dee8..58a889d 100755
--- a/setup.py
+++ b/setup.py
@@ -53,7 +53,7 @@ setup(
],
entry_points={
'console_scripts': [
- 'sshuttle = sshuttle.__main__',
+ 'sshuttle = sshuttle.cmdline:main',
],
},
tests_require=['pytest', 'mock'],