summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSam Tay <sam.chong.tay@gmail.com>2020-06-17 23:30:33 -0700
committerSam Tay <sam.chong.tay@gmail.com>2020-06-17 23:30:33 -0700
commitec92f930344d364e3be359a41aebea78f8205fa7 (patch)
treeb041fa1404d383d44be46c9e1f4e8e94ef75e254 /Cargo.toml
parentd422c8424ae76fc85e0fdf55257e0cee7fa38271 (diff)
Use async http requests via tokio
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 03d6481..ddb10cd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,8 +14,9 @@ serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_yaml = "0.8"
-reqwest = { version = "0.10", features = ["blocking"] }
-flate2 = "1.0"
+reqwest = { version = "0.10", features = ["gzip", "json"] }
+futures = "0.3"
+tokio = { version = "0.2", features = ["full"] }
lazy_static = "1.4"
minimad = "0.6"