summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSam Tay <sam.chong.tay@gmail.com>2020-06-11 00:50:41 -0700
committerSam Tay <sam.chong.tay@gmail.com>2020-06-11 00:50:41 -0700
commit37ab4c85f9d8bf1e113c4b1b419c0d17ec72b84e (patch)
tree694e9e3ad3303f8213432d6fd44a6455ba982a21 /Cargo.toml
parent7ac11eee2b38522f22fa44227ffb6411b4f758e4 (diff)
...Use cursive instead
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 12 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bfd9fb9..84aa6f0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,16 +7,21 @@ edition = "2018"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-crossterm = { version = "0.17", features = ["event-stream"] }
+thiserror = "1.0"
clap = "2.33"
directories = "2.0"
-flate2 = "1.0"
-reqwest = { version = "0.10", features = ["blocking"] }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"
serde_yaml = "0.8"
-termimad = "0.8"
-minimad = "0.6"
-tui = { version = "0.9", default-features = false, features = ['crossterm'] }
+
+reqwest = { version = "0.10", features = ["blocking"] }
+flate2 = "1.0"
+
lazy_static = "1.4"
-thiserror = "1.0"
+minimad = "0.6"
+termimad = "0.8"
+
+crossterm = { version = "0.17", features = ["event-stream"] }
+pulldown-cmark = { version = "0.7", default-features = false }
+unicode-width = "0.1.5"
+cursive = { version = "0.15", features = ["toml"] }