summaryrefslogtreecommitdiffstats
path: root/openpgp/fuzz/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp/fuzz/Cargo.toml')
-rw-r--r--openpgp/fuzz/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/openpgp/fuzz/Cargo.toml b/openpgp/fuzz/Cargo.toml
new file mode 100644
index 00000000..55609cf1
--- /dev/null
+++ b/openpgp/fuzz/Cargo.toml
@@ -0,0 +1,47 @@
+[package]
+name = "sequoia-openpgp-fuzz"
+version = "0.0.0"
+publish = false
+edition = "2021"
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies]
+anyhow = "1"
+lazy_static = "1"
+libfuzzer-sys = "0.4"
+
+[dependencies.sequoia-openpgp]
+path = ".."
+default-features = false
+features = ["crypto-fuzzing", "allow-experimental-crypto", "allow-variable-time-crypto"]
+
+# Prevent this from interfering with workspaces
+[workspace]
+members = ["."]
+
+[profile.release]
+debug = 1
+
+[[bin]]
+name = "cert_from_bytes"
+path = "fuzz_targets/cert_from_bytes.rs"
+test = false
+doc = false
+
+[[bin]]
+name = "inline_verify_from_bytes"
+path = "fuzz_targets/inline_verify_from_bytes.rs"
+
+[[bin]]
+name = "csf_verify_from_bytes"
+path = "fuzz_targets/csf_verify_from_bytes.rs"
+test = false
+doc = false
+
+[[bin]]
+name = "decrypt_from_bytes"
+path = "fuzz_targets/decrypt_from_bytes.rs"
+test = false
+doc = false