summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml43
1 files changed, 34 insertions, 9 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 11ce5934..2b33b04e 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -1,14 +1,17 @@
[package]
name = "sequoia-openpgp"
description = "OpenPGP data types and associated machinery"
-version = "0.15.0"
+version = "0.17.0"
authors = [
+ "Igor Matuszewski <igor@sequoia-pgp.org>",
"Justus Winter <justus@sequoia-pgp.org>",
"Kai Michaelis <kai@sequoia-pgp.org>",
"Neal H. Walfield <neal@sequoia-pgp.org>",
+ "Nora Widdecke <nora@sequoia-pgp.org>",
+ "Wiktor Kwapisiewicz <wiktor@sequoia-pgp.org>",
]
build = "build.rs"
-documentation = "https://docs.sequoia-pgp.org/0.15.0/sequoia_openpgp"
+documentation = "https://docs.sequoia-pgp.org/0.17.0/sequoia_openpgp"
homepage = "https://sequoia-pgp.org/"
repository = "https://gitlab.com/sequoia-pgp/sequoia"
readme = "README.md"
@@ -23,29 +26,43 @@ maintenance = { status = "actively-developed" }
[dependencies]
anyhow = "1"
-buffered-reader = { path = "../buffered-reader", version = "0.14", default-features = false }
-base64 = "0.11"
+buffered-reader = { path = "../buffered-reader", version = "0.17", default-features = false }
+base64 = ">= 0.11, < 0.13"
bzip2 = { version = "0.3.2", optional = true }
flate2 = { version = "1.0.1", optional = true }
idna = "0.2"
lalrpop-util = "0.17"
lazy_static = "1.3"
+libc = "0.2"
memsec = "0.5.6"
-nettle = "7"
-quickcheck = { version = "0.9", default-features = false }
-rand = { version = "0.7", default-features = false }
+nettle = { version = "7", optional = true }
+quickcheck = { version = "0.9", default-features = false, optional = true }
+rand = { version = "0.7", default-features = false, optional = true }
regex = "1"
thiserror = "1"
-unicode-normalization = "< 0.1.10"
+
+# XXX: We need to pin some dependencies to keep our MSRV at 1.34. If
+# you are packaging Sequoia, feel free to drop these pins if your
+# compiler is newer.
+backtrace = "= 0.3.46"
+unicode-normalization = "= 0.1.9"
[build-dependencies]
lalrpop = "0.17"
[dev-dependencies]
+quickcheck = { version = "0.9", default-features = false }
+rand = { version = "0.7", default-features = false }
+
+# XXX: We need to pin some dependencies to keep our MSRV at 1.34. If
+# you are packaging Sequoia, feel free to drop these pins if your
+# compiler is newer.
rpassword = "=4.0.3"
[features]
-default = ["compression"]
+default = ["compression", "crypto-nettle"]
+# TODO(#333): Allow for/implement more backends
+crypto-nettle = ["nettle"]
# The compression algorithms.
compression = ["compression-deflate", "compression-bzip2"]
@@ -56,6 +73,14 @@ compression-bzip2 = ["bzip2", "buffered-reader/compression-bzip2"]
vendored = ["vendored-nettle"]
vendored-nettle = ["nettle/vendored"]
+# Testing, debugging, and fuzzing.
+
+# XXX: This feature should just be called 'quickcheck'. However, this
+# currently collides with the implicitly created feature for the
+# optional dependency 'quickcheck'. Blocker:
+# https://github.com/rust-lang/cargo/issues/5565
+x-quickcheck = ["quickcheck", "rand"]
+
[[example]]
name = "pad"
required-features = ["compression-deflate"]