summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml10
1 files changed, 0 insertions, 10 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index b88eb0ab..13e0a67a 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -38,8 +38,6 @@ lazy_static = "1.3"
libc = "0.2"
memsec = "0.5.6"
nettle = { version = "7", optional = true }
-quickcheck = { version = "0.9", default-features = false, optional = true }
-rand = { version = "0.7", default-features = false, optional = true }
regex = "1"
thiserror = "1"
backtrace = "0.3.46"
@@ -75,14 +73,6 @@ compression-bzip2 = ["bzip2", "buffered-reader/compression-bzip2"]
vendored = ["vendored-nettle"]
vendored-nettle = ["nettle/vendored"]
-# Testing, debugging, and fuzzing.
-
-# XXX: This feature should just be called 'quickcheck'. However, this
-# currently collides with the implicitly created feature for the
-# optional dependency 'quickcheck'. Blocker:
-# https://github.com/rust-lang/cargo/issues/5565
-x-quickcheck = ["quickcheck", "rand"]
-
[[example]]
name = "pad"
required-features = ["compression-deflate"]