summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index dc5547de..f4ede36c 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -81,6 +81,8 @@ ecdsa = { version = "0.16", optional = true, features = ["hazmat", "arithmetic"]
# std::error::Error.
ed25519 = { version = "2", default-features = false, features = ["std"], optional = true }
ed25519-dalek = { version = "2", features = ["rand_core", "zeroize"], optional = true }
+generic-array = { version = "0.14.4", optional = true }
+hkdf = { version = "0.12", optional = true }
idea = { version = "0.5", optional = true, features = ["zeroize"] }
md-5 = { version = "0.10", features = ["oid"], optional = true }
num-bigint-dig = { version = "0.8", default-features = false, optional = true }
@@ -125,12 +127,13 @@ crypto-rust = [
"sha1collisiondetection/digest-trait", "sha1collisiondetection/oid",
"dep:twofish", "dep:typenum", "dep:x25519-dalek", "dep:p256",
"dep:rand", "rand?/getrandom", "dep:rand_core", "rand_core?/getrandom",
- "dep:ecdsa", "dep:aes-gcm", "dep:dsa"
+ "dep:ecdsa", "dep:aes-gcm", "dep:dsa", "dep:hkdf",
]
crypto-cng = [
"dep:cipher", "dep:eax", "dep:winapi", "dep:win-crypto-ng",
"dep:ed25519", "dep:ed25519-dalek",
- "dep:num-bigint-dig", "dep:aes-gcm", "dep:rand_core"
+ "dep:num-bigint-dig", "dep:aes-gcm", "dep:rand_core",
+ "dep:hkdf", "dep:sha2",
]
crypto-openssl = ["dep:openssl", "dep:openssl-sys"]
crypto-botan = ["dep:botan", "botan?/botan3"]