summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index f9ce98ee..4e4f1a16 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -62,7 +62,7 @@ idea = { version = "0.3.0", optional = true }
md-5 = { version = "0.9.1", optional = true }
num-bigint-dig = { version = "0.6", default-features = false, optional = true }
p256 = { version = "0.8", optional = true, features = ["ecdh", "ecdsa"] }
-rand07 = { package = "rand", version = "0.7.3", optional = true }
+rand = { version = "0.7.3", optional = true }
rand_core = { version = "0.6", optional = true }
ripemd160 = { version = "0.9.1", optional = true }
rsa = { version = "0.3.0", optional = true }
@@ -79,7 +79,7 @@ winapi = { version = "0.3.8", default-features = false, features = ["bcrypt"], o
[target.'cfg(all(target_arch = "wasm32", target_os = "unknown"))'.dependencies]
chrono = { version = "0.4.10", default-features = false, features = ["std", "wasmbind"] }
getrandom = { version = "0.2", features = ["js"] }
-rand07 = { package = "rand", version = "0.7", features = ["wasm-bindgen"] }
+rand = { version = "0.7", features = ["wasm-bindgen"] }
[build-dependencies]
lalrpop = { version = ">=0.17", default-features = false }
@@ -96,7 +96,7 @@ default = ["compression", "crypto-nettle"]
crypto-nettle = ["nettle"]
crypto-rust = [
"aes", "block-modes", "block-padding", "blowfish", "cast5", "cipher", "des",
- "digest", "eax", "ed25519-dalek", "generic-array", "idea", "md-5", "num-bigint-dig", "rand07",
+ "digest", "eax", "ed25519-dalek", "generic-array", "idea", "md-5", "num-bigint-dig", "rand",
"ripemd160", "rsa", "sha-1", "sha2", "twofish", "typenum", "x25519-dalek", "p256",
"rand_core", "rand_core/getrandom", "ecdsa"
]