summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index ed1f7ded..21c8c73f 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -69,7 +69,9 @@ digest = { version = "0.10", optional = true }
eax = { version = "0.5", optional = true }
ecb = { version = "0.1", optional = true }
ecdsa = { version = "0.16", optional = true, features = ["hazmat", "arithmetic"] } # XXX
-# We don't directly use ed25519, but ed25519-dalek reexports it and we need the std feature.
+# We don't directly use ed25519, but ed25519-dalek reexports it and we
+# need the std feature, at least so that ed25519::Error implements
+# std::error::Error.
ed25519 = { version = "1", default-features = false, features = ["std"], optional = true }
ed25519-dalek = { version = "1", default-features = false, features = ["rand", "u64_backend"], optional = true }
generic-array = { version = "0.14.4", optional = true }
@@ -131,7 +133,7 @@ crypto-rust = [
"rand_core", "rand_core/getrandom", "ecdsa", "aes-gcm"
]
crypto-cng = [
- "cipher", "eax", "winapi", "win-crypto-ng", "ed25519-dalek",
+ "cipher", "eax", "winapi", "win-crypto-ng", "ed25519", "ed25519-dalek",
"num-bigint-dig", "aes-gcm"
]
crypto-openssl = ["openssl", "openssl-sys"]