summaryrefslogtreecommitdiffstats
path: root/openpgp-ffi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'openpgp-ffi/Cargo.toml')
-rw-r--r--openpgp-ffi/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/openpgp-ffi/Cargo.toml b/openpgp-ffi/Cargo.toml
new file mode 100644
index 00000000..1bb6aab1
--- /dev/null
+++ b/openpgp-ffi/Cargo.toml
@@ -0,0 +1,35 @@
+[package]
+name = "sequoia-openpgp-ffi"
+description = "C API for Sequoia's low-level OpenPGP crate"
+version = "0.3.0"
+authors = [
+ "Justus Winter <justus@sequoia-pgp.org>",
+ "Kai Michaelis <kai@sequoia-pgp.org>",
+ "Neal H. Walfield <neal@sequoia-pgp.org>",
+]
+documentation = "https://docs.sequoia-pgp.org/sequoia_openpgp_ffi"
+homepage = "https://sequoia-pgp.org/"
+repository = "https://gitlab.com/sequoia-pgp/sequoia"
+readme = "../README.md"
+keywords = ["cryptography", "openpgp", "pgp", "encryption", "signing"]
+categories = ["cryptography", "authentication", "development-tools::ffi",
+ "email"]
+license = "GPL-3.0"
+
+[badges]
+gitlab = { repository = "sequoia-pgp/sequoia" }
+maintenance = { status = "actively-developed" }
+
+[dependencies]
+sequoia-ffi-macros = { path = "../ffi-macros" }
+sequoia-openpgp = { path = "../openpgp" }
+failure = "0.1.2"
+lazy_static = "1.0.0"
+libc = "0.2.33"
+time = "0.1.40"
+
+[dev-dependencies]
+nettle = "2.0"
+
+[lib]
+crate-type = ["lib", "cdylib", "staticlib"]