summaryrefslogtreecommitdiffstats
path: root/ipc/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ipc/Cargo.toml')
-rw-r--r--ipc/Cargo.toml11
1 files changed, 5 insertions, 6 deletions
diff --git a/ipc/Cargo.toml b/ipc/Cargo.toml
index 49b2d63e..dc680257 100644
--- a/ipc/Cargo.toml
+++ b/ipc/Cargo.toml
@@ -25,9 +25,9 @@ sequoia-core = { path = "../core", version = "0.20" }
anyhow = "1"
buffered-reader = { path = "../buffered-reader", version = "0.20", default-features = false }
-capnp-rpc = "0.10"
+capnp-rpc = "0.13"
fs2 = "0.4.2"
-futures = "0.1"
+futures = "0.3"
lalrpop-util = "0.19"
lazy_static = "1.3"
libc = "0.2.33"
@@ -35,10 +35,9 @@ memsec = { version = "0.6", default-features = false }
rand = { version = "0.7", default-features = false }
tempfile = "3.0"
thiserror = "1"
-tokio = "0.1"
-tokio-core = "0.1"
-tokio-io = "0.1.4"
-parity-tokio-ipc = "0.4"
+tokio = { version = "0.2", features = ["rt-core", "rt-util", "tcp"] }
+tokio-util = { version = "0.3", features = ["compat"] }
+parity-tokio-ipc = "0.7"
socket2 = "0.3.11"
[target.'cfg(windows)'.dependencies]