summaryrefslogtreecommitdiffstats
path: root/buffered-reader/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'buffered-reader/Cargo.toml')
-rw-r--r--buffered-reader/Cargo.toml12
1 files changed, 10 insertions, 2 deletions
diff --git a/buffered-reader/Cargo.toml b/buffered-reader/Cargo.toml
index 68f4c60d..1702ac97 100644
--- a/buffered-reader/Cargo.toml
+++ b/buffered-reader/Cargo.toml
@@ -4,5 +4,13 @@ version = "0.1.0"
authors = ["Neal H. Walfield <neal@gnu.org>"]
[dependencies]
-bzip2 = "0.3.2"
-flate2 = "1.0.1"
+bzip2 = { version = "0.3.2", optional = true }
+flate2 = { version = "1.0.1", optional = true }
+
+[features]
+default = ["compression"]
+
+# The compression algorithms.
+compression = ["compression-deflate", "compression-bzip2"]
+compression-deflate = ["flate2"]
+compression-bzip2 = ["bzip2"]