summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 8 insertions, 14 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 43343ed6..87304717 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,25 +3,19 @@ name = "sequoia"
version = "0.1.0"
authors = ["Neal H. Walfield <neal@gnu.org>"]
+[workspace]
+
[dependencies]
-base64 = "0.8.0"
-bzip2 = "0.3.2"
-flate2 = "0.2"
-futures = "0.1"
-hyper = "0.11"
-hyper-tls = "0.1.2"
-libc = "0.2.33"
-native-tls = "0.1.4"
-nom = "3.2.0"
-num = "0.1.40"
-num-derive = "0.1.41"
-percent-encoding = "1.0.1"
-tokio-core = "0.1"
+buffered-reader = { path = "buffered-reader" }
+openpgp = { path = "openpgp" }
+sequoia-core = { path = "core" }
+sequoia-ffi = { path = "ffi" }
+sequoia-net = { path = "net" }
+sequoia-store = { path = "store" }
[lib]
name = "sequoia"
path = "src/lib.rs"
-crate-type = ["lib", "dylib"]
[[bin]]
doc = false