summaryrefslogtreecommitdiffstats
path: root/tool/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@pep-project.org>2017-12-21 16:31:44 +0100
committerJustus Winter <justus@pep-project.org>2017-12-21 18:02:35 +0100
commitb6fae6ab962f0061f18158d04c4ef6a7d06498cf (patch)
tree3702a1234e4e25e06f682681c7ea799ef49131eb /tool/Cargo.toml
parentf2e693585e65d8c4873f5bbef8fd32c93e7a2d9e (diff)
tool: New crate.
- A command line tool to interact with Sequoia. Useful for debugging and development.
Diffstat (limited to 'tool/Cargo.toml')
-rw-r--r--tool/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/tool/Cargo.toml b/tool/Cargo.toml
new file mode 100644
index 00000000..c1db4614
--- /dev/null
+++ b/tool/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "sequoia-tool"
+version = "0.1.0"
+authors = ["Justus Winter <justus@pep-project.org>"]
+
+[dependencies]
+openpgp = { path = "../openpgp" }
+sequoia-core = { path = "../core" }
+sequoia-net = { path = "../net" }
+clap = "2.27.1"
+
+[[bin]]
+name = "sq"
+path = "src/usage.rs"