summaryrefslogtreecommitdiffstats
path: root/store/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-03-09 11:42:45 +0100
committerJustus Winter <justus@sequoia-pgp.org>2020-03-09 18:09:50 +0100
commit391a4b92c977cd64dfd131f3e29b0bc8d756d064 (patch)
treeb5b96ff935853cef9ee22e01890c248a791e724e /store/Cargo.toml
parent58d662c6d37dd1b0dccd4d0ce30290b8ede408e9 (diff)
Switch from failure to anyhow.
- Use the anyhow crate instead of failure to implement the dynamic side of our error handling. anyhow::Error derefs to dyn std::error::Error, allowing better interoperability with other stdlib-based error handling libraries. - Fixes #444.
Diffstat (limited to 'store/Cargo.toml')
-rw-r--r--store/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/store/Cargo.toml b/store/Cargo.toml
index d56bf09d..a54a6008 100644
--- a/store/Cargo.toml
+++ b/store/Cargo.toml
@@ -30,9 +30,9 @@ sequoia-openpgp = { path = "../openpgp", version = "0.15" }
sequoia-core = { path = "../core", version = "0.15" }
sequoia-ipc = { path = "../ipc", version = "0.15" }
sequoia-net = { path = "../net", version = "0.15" }
+anyhow = "1"
capnp = "0.10"
capnp-rpc = "0.10"
-failure = "0.1.2"
futures = "0.1.17"
rand = { version = "0.7", default-features = false }
rusqlite = "0.19"