summaryrefslogtreecommitdiffstats
path: root/store/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2018-01-11 17:07:50 +0100
committerJustus Winter <justus@sequoia-pgp.org>2018-01-17 11:50:30 +0100
commit6b3408662c9d3a4c27c6883f7bd1f88e60981094 (patch)
treed6d2f13742f935fe8ddf433f404d76a5d1353194 /store/Cargo.toml
parentdbf75dedefc7c14705538d63257d8f8cf4a594ff (diff)
store: Periodically update keys from the network.
- Update all keys stored in a store with network policy 'encrypted' and 'insecure' periodically using the SKS keyserver pool. - Slightly amend the net::ipc interface so that servers can spawn futures on the reactor. - As a background service cannot directly communicate failures, this patch adds a logging mechanism. - In sq, display the key update timestamp, and the status of the last update.
Diffstat (limited to 'store/Cargo.toml')
-rw-r--r--store/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/store/Cargo.toml b/store/Cargo.toml
index d994f408..47fbd373 100644
--- a/store/Cargo.toml
+++ b/store/Cargo.toml
@@ -15,7 +15,9 @@ sequoia-net = { path = "../net" }
capnp = "0.8"
capnp-rpc = "0.8"
futures = "0.1.17"
+rand = "0.3"
rusqlite = "0.12.0"
+time = "0.1.38"
tokio-core = "0.1.10"
tokio-io = "0.1.4"