summaryrefslogtreecommitdiffstats
path: root/store/Cargo.toml
diff options
context:
space:
mode:
authorIgor Matuszewski <igor@sequoia-pgp.org>2020-10-20 18:40:21 +0200
committerIgor Matuszewski <igor@sequoia-pgp.org>2020-10-23 12:05:54 +0200
commit3fd21d2f10b9d2946c7c6fd5af8cc38a69402996 (patch)
treec135754ead003b8844b07eaeba2905cd082614cc /store/Cargo.toml
parentd30e05a43655a3884c6119e282e0ac58a9c723f7 (diff)
store: Migrate to std::futures
Diffstat (limited to 'store/Cargo.toml')
-rw-r--r--store/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/store/Cargo.toml b/store/Cargo.toml
index 7cff7319..c5e1c452 100644
--- a/store/Cargo.toml
+++ b/store/Cargo.toml
@@ -37,21 +37,21 @@ sequoia-core = { path = "../core", version = "0.20" }
sequoia-ipc = { path = "../ipc", version = "0.20", default-features = false }
sequoia-net = { path = "../net", version = "0.20", default-features = false }
anyhow = "1"
-capnp = "0.10"
-capnp-rpc = "0.10"
-futures = "0.1.17"
+capnp = "0.13"
+capnp-rpc = "0.13"
+futures-util = "0.3"
rand = { version = "0.7", default-features = false }
rusqlite = "0.24"
thiserror = "1"
-tokio-core = "0.1.10"
-tokio-io = "0.1.4"
+tokio = { version = "0.2", features = ["rt-core", "tcp", "io-driver", "time"] }
+tokio-util = { version = "0.3", features = ["compat"] }
[target.'cfg(target_os="android")'.dependencies.rusqlite]
version = "0.24.0"
features = ["bundled"]
[build-dependencies]
-capnpc = "0.10"
+capnpc = "0.13"
[lib]
name = "sequoia_store"