summaryrefslogtreecommitdiffstats
path: root/sqv/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-03-09 11:42:45 +0100
committerJustus Winter <justus@sequoia-pgp.org>2020-03-09 18:09:50 +0100
commit391a4b92c977cd64dfd131f3e29b0bc8d756d064 (patch)
treeb5b96ff935853cef9ee22e01890c248a791e724e /sqv/Cargo.toml
parent58d662c6d37dd1b0dccd4d0ce30290b8ede408e9 (diff)
Switch from failure to anyhow.
- Use the anyhow crate instead of failure to implement the dynamic side of our error handling. anyhow::Error derefs to dyn std::error::Error, allowing better interoperability with other stdlib-based error handling libraries. - Fixes #444.
Diffstat (limited to 'sqv/Cargo.toml')
-rw-r--r--sqv/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/sqv/Cargo.toml b/sqv/Cargo.toml
index b41f110e..13dce931 100644
--- a/sqv/Cargo.toml
+++ b/sqv/Cargo.toml
@@ -22,9 +22,10 @@ maintenance = { status = "actively-developed" }
[dependencies]
sequoia-openpgp = { path = "../openpgp", version = "0.15", default-features = false }
+anyhow = "1"
chrono = "0.4"
clap = "2.32.0"
-failure = "0.1.2"
+
[build-dependencies]
clap = "2.27.1"