summaryrefslogtreecommitdiffstats
path: root/sq/Cargo.toml
diff options
context:
space:
mode:
authorNora Widdecke <nora@sequoia-pgp.org>2020-12-10 11:04:09 +0100
committerNora Widdecke <nora@sequoia-pgp.org>2020-12-10 17:08:07 +0100
commit386b3bc3bbaf7a7abaaa2c2587b0510c161cb67a (patch)
treeefd59162fef5a8583690b8ad9844f988d18c8471 /sq/Cargo.toml
parente9439f7c4b902265d3f599c224e5e5ac9798014e (diff)
Correct minimal versions.
- Versions required by feature or API usage: - anyhow 1.0.5. - We use `impl From<anyhow::Error> for Box<dyn std::error::Error + Send + Sync + 'static>`, introduced in 1.0.5. - tokio 0.2.19 - We use `tokio::net::tcp::OwnedReadHalf`, introduced in 0.2.19. - chrono 0.4.10 - We use the `std` feature, introduced in 0.4.10. - thiserror 1.0.2 - futures and futures-util 0.3.5 - tempfile 3.1 - c_doctests require the same version of rand both as direct dependency and through tempfile. - Yanked versions: - structopt 0.3.11. 0.3.8 to 0.3.10 were yanked. - socket2 0.3.16. 0.3.0 to 0.3.15 were yanked. - Update our dependencies to the package versions required by other dependencies, e.g. structopt requires lazy_static 1.4.0. - clap 2.33 - lazy_static to 1.4.0 - libc to 0.2.66 - proc-macro2 to 1.0.7 - syn to 1.0.5. - winapi 0.3.8
Diffstat (limited to 'sq/Cargo.toml')
-rw-r--r--sq/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/sq/Cargo.toml b/sq/Cargo.toml
index fe88d628..03008594 100644
--- a/sq/Cargo.toml
+++ b/sq/Cargo.toml
@@ -29,18 +29,18 @@ sequoia-core = { path = "../core", version = "0.20", default-features = false }
sequoia-ipc = { path = "../ipc", version = "0.20", default-features = false }
sequoia-net = { path = "../net", version = "0.20", default-features = false }
sequoia-store = { path = "../store", version = "0.20", default-features = false }
-anyhow = "1"
-chrono = "0.4"
-clap = "2.32.0"
+anyhow = "1.0.5"
+chrono = "0.4.10"
+clap = "2.33"
itertools = "0.9"
prettytable-rs = "0.8.0"
-tempfile = "3.0.4"
+tempfile = "3.1"
crossterm = "0.13"
-tokio = { version = "0.2", features = ["rt-core", "io-util", "io-driver"] }
+tokio = { version = "0.2.19", features = ["rt-core", "io-util", "io-driver"] }
rpassword = "5.0"
[build-dependencies]
-clap = "2.32.0"
+clap = "2.33"
[dev-dependencies]
assert_cli = "0.6"