summaryrefslogtreecommitdiffstats
path: root/sq/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2021-01-15 10:50:44 +0100
committerJustus Winter <justus@sequoia-pgp.org>2021-01-15 11:34:49 +0100
commita9ac52a46fa38d60664ddd8f2d046803ba111a33 (patch)
tree589f453cb9501433443ddb483cf137c2c7fb5c36 /sq/Cargo.toml
parent263df5c5510a0685cc98274234456510aaa16713 (diff)
sq: Drop public key store integration.
- We want to release sq without it depending on the key store. The keystore is little more than a prototype, but because it keeps state, it has the potential to break if we change it later.
Diffstat (limited to 'sq/Cargo.toml')
-rw-r--r--sq/Cargo.toml4
1 files changed, 0 insertions, 4 deletions
diff --git a/sq/Cargo.toml b/sq/Cargo.toml
index 1c79f069..a32c32b6 100644
--- a/sq/Cargo.toml
+++ b/sq/Cargo.toml
@@ -25,15 +25,12 @@ maintenance = { status = "actively-developed" }
buffered-reader = { path = "../buffered-reader", version = "1.0.0", default-features = false }
sequoia-openpgp = { path = "../openpgp", version = "1.0.0", default-features = false }
sequoia-autocrypt = { path = "../autocrypt", version = "0.22", default-features = false }
-sequoia-core = { path = "../core", version = "0.22", default-features = false }
sequoia-ipc = { path = "../ipc", version = "0.22", default-features = false }
sequoia-net = { path = "../net", version = "0.22", default-features = false }
-sequoia-store = { path = "../store", version = "0.22", default-features = false }
anyhow = "1.0.18"
chrono = "0.4.10"
clap = "2.33"
itertools = "0.9"
-prettytable-rs = "0.8.0"
tempfile = "3.1"
crossterm = "0.13"
tokio = { version = "0.2.19", features = ["rt-core", "io-util", "io-driver"] }
@@ -55,7 +52,6 @@ path = "src/sq-usage.rs"
default = [
"buffered-reader/compression",
"sequoia-openpgp/default",
- "sequoia-store/background-services"
]
crypto-nettle = ["sequoia-openpgp/crypto-nettle"]
crypto-cng = ["sequoia-openpgp/crypto-cng"]