summaryrefslogtreecommitdiffstats
path: root/sop/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-04-15 10:36:40 +0200
committerJustus Winter <justus@sequoia-pgp.org>2020-04-21 17:10:27 +0200
commit8af5e4357c7348fe231b70a0fbe19788137caaa3 (patch)
treee8c28ca95583b4e4272cc95f7b2f4f1997dab6ac /sop/Cargo.toml
parent50c6526133ae72adc26800f3cc8e9884dab88518 (diff)
sop: An implementation of the Stateless OpenPGP CLI using Sequoia.
- This adds a new frontend to Sequoia that implements the Stateless OpenPGP Command Line Interface. - Compared to sq, sop has a much smaller feature set and hence a smaller set of dependencies. It is less opinionated, and tries to faithfully implement the SOP protocol. We will use it to test Sequoia using the OpenPGP Interoperability Test Suite.
Diffstat (limited to 'sop/Cargo.toml')
-rw-r--r--sop/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/sop/Cargo.toml b/sop/Cargo.toml
new file mode 100644
index 00000000..4e30997f
--- /dev/null
+++ b/sop/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+name = "sequoia-sop"
+description = "An implementation of the Stateless OpenPGP Command Line Interface using Sequoia"
+version = "0.16.0"
+authors = [
+ "Justus Winter <justus@sequoia-pgp.org>",
+]
+documentation = "https://docs.sequoia-pgp.org/0.16.0/sop"
+homepage = "https://sequoia-pgp.org/"
+repository = "https://gitlab.com/sequoia-pgp/sequoia"
+readme = "README.md"
+keywords = ["cryptography", "openpgp", "pgp", "sop", "stateless-openpgp-protocol"]
+categories = ["cryptography", "command-line-utilities"]
+license = "GPL-2.0-or-later"
+edition = "2018"
+
+[badges]
+gitlab = { repository = "sequoia-pgp/sequoia" }
+maintenance = { status = "actively-developed" }
+
+[dependencies]
+sequoia-openpgp = { path = "../openpgp", version = "0.16" }
+anyhow = "1"
+chrono = "0.4"
+structopt = { version = "0.3", default-features = false }
+thiserror = "1"
+
+[[bin]]
+name = "sqop"
+path = "src/main.rs"