summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorNora Widdecke <nora@sequoia-pgp.org>2020-12-10 11:04:09 +0100
committerNora Widdecke <nora@sequoia-pgp.org>2020-12-10 17:08:07 +0100
commit386b3bc3bbaf7a7abaaa2c2587b0510c161cb67a (patch)
treeefd59162fef5a8583690b8ad9844f988d18c8471 /openpgp/Cargo.toml
parente9439f7c4b902265d3f599c224e5e5ac9798014e (diff)
Correct minimal versions.
- Versions required by feature or API usage: - anyhow 1.0.5. - We use `impl From<anyhow::Error> for Box<dyn std::error::Error + Send + Sync + 'static>`, introduced in 1.0.5. - tokio 0.2.19 - We use `tokio::net::tcp::OwnedReadHalf`, introduced in 0.2.19. - chrono 0.4.10 - We use the `std` feature, introduced in 0.4.10. - thiserror 1.0.2 - futures and futures-util 0.3.5 - tempfile 3.1 - c_doctests require the same version of rand both as direct dependency and through tempfile. - Yanked versions: - structopt 0.3.11. 0.3.8 to 0.3.10 were yanked. - socket2 0.3.16. 0.3.0 to 0.3.15 were yanked. - Update our dependencies to the package versions required by other dependencies, e.g. structopt requires lazy_static 1.4.0. - clap 2.33 - lazy_static to 1.4.0 - libc to 0.2.66 - proc-macro2 to 1.0.7 - syn to 1.0.5. - winapi 0.3.8
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 000de1d0..55be6cd2 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -25,7 +25,7 @@ gitlab = { repository = "sequoia-pgp/sequoia" }
maintenance = { status = "actively-developed" }
[dependencies]
-anyhow = "1"
+anyhow = "1.0.5"
buffered-reader = { path = "../buffered-reader", version = "0.20", default-features = false }
base64 = "0.13"
bzip2 = { version = "0.4", optional = true }
@@ -33,13 +33,13 @@ dyn-clone = "1"
flate2 = { version = "1.0.1", optional = true }
idna = "0.2"
lalrpop-util = "0.19"
-lazy_static = "1.3"
-libc = "0.2"
+lazy_static = "1.4.0"
+libc = "0.2.66"
memsec = { version = "0.6", default-features = false }
nettle = { version = "7", optional = true }
regex = "1"
sha1collisiondetection = { version = "0.2.2", default-features = false, features = ["std"] }
-thiserror = "1"
+thiserror = "1.0.2"
backtrace = "0.3.46"
unicode-normalization = "0.1.9"
@@ -47,11 +47,11 @@ unicode-normalization = "0.1.9"
win-crypto-ng = { version = "0.4", features = ["rand", "block-cipher"], optional = true }
num-bigint-dig = { version = "0.6", default-features = false, optional = true }
ed25519-dalek = { version = "1", default-features = false, features = ["rand", "u64_backend"], optional = true }
-winapi = { version = "0.3", default-features = false, features = ["bcrypt"], optional = true }
+winapi = { version = "0.3.8", default-features = false, features = ["bcrypt"], optional = true }
eax = "0.3"
[target.'cfg(all(target_arch = "wasm32", target_os = "unknown"))'.dependencies]
-chrono = { version = "0.4", default-features = false, features = ["std"] }
+chrono = { version = "0.4.10", default-features = false, features = ["std"] }
[build-dependencies]
lalrpop = "0.19"