summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2023-09-22 17:33:59 +0200
committerJustus Winter <justus@sequoia-pgp.org>2023-09-22 17:36:26 +0200
commitc62fb995baee091ef6009a06068b88421d43a994 (patch)
tree8c553b2bacd9fe655dfd50b260731bf8455efd9b /openpgp/Cargo.toml
parent63d28ccf695ccb438c03b505876c5dcf13749133 (diff)
openpgp: Add tests that scan for secrets leaking into the heap.
- Fixes #989.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 71a52df2..08719619 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -147,3 +147,7 @@ required-features = ["compression-deflate"]
[[bench]]
name = "run_benchmarks"
harness = false
+
+[[example]]
+name = "secret-leak-detector"
+path = "tests/secret-leak-detector/detector.rs"