summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorNeal H. Walfield <neal@pep.foundation>2023-10-26 13:50:57 +0200
committerNeal H. Walfield <neal@pep.foundation>2023-10-26 13:51:55 +0200
commit20556b4d61e8f5e4c087af8064ea87c3270e28a2 (patch)
tree5d7cea3257d94f50dc319de72e396b39c1815bcf /openpgp/Cargo.toml
parentd691ddb2ff48f0b553180f3ae9601069021d787f (diff)
openpgp: Upgrade ed25519
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 889d7bd1..50d450de 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -76,7 +76,7 @@ ecdsa = { version = "0.16", optional = true, features = ["hazmat", "arithmetic"]
# We don't directly use ed25519, but ed25519-dalek reexports it and we
# need the std feature, at least so that ed25519::Error implements
# std::error::Error.
-ed25519 = { version = "1", default-features = false, features = ["std"], optional = true }
+ed25519 = { version = "2", default-features = false, features = ["std"], optional = true }
ed25519-dalek = { version = "2", features = ["rand_core", "zeroize"], optional = true }
generic-array = { version = "0.14.4", optional = true }
idea = { version = "0.5", optional = true, features = ["zeroize"] }