summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2023-09-22 12:13:15 +0200
committerJustus Winter <justus@sequoia-pgp.org>2023-09-22 15:32:46 +0200
commit03deb1e127ece52bab798dd128addca5948e0d91 (patch)
tree7d202e6d56f6fd6d36988d7214dee9ba4de8f834 /openpgp/Cargo.toml
parent7adca50f172bc1d4d983231a8682d252f6c2fadc (diff)
openpgp: Enable the zeroize feature in the Dalek crates.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 8fd3a6fb..baf72a51 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -77,7 +77,7 @@ ecdsa = { version = "0.16", optional = true, features = ["hazmat", "arithmetic"]
# need the std feature, at least so that ed25519::Error implements
# std::error::Error.
ed25519 = { version = "1", default-features = false, features = ["std"], optional = true }
-ed25519-dalek = { version = "2", features = ["rand_core"], optional = true }
+ed25519-dalek = { version = "2", features = ["rand_core", "zeroize"], optional = true }
generic-array = { version = "0.14.4", optional = true }
idea = { version = "0.5", optional = true }
md-5 = { version = "0.10", features = ["oid"], optional = true }
@@ -89,7 +89,7 @@ rsa = { version = "0.9.0", optional = true }
sha2 = { version = "0.10", features = ["oid"], optional = true }
twofish = { version = "0.7", optional = true }
typenum = { version = "1.12.0", optional = true }
-x25519-dalek = { version = "2", optional = true, default-features = false, features = ["static_secrets"] }
+x25519-dalek = { version = "2", optional = true, default-features = false, features = ["static_secrets", "zeroize"] }
[target.'cfg(windows)'.dependencies]
win-crypto-ng = { version = ">=0.4, <0.6", features = ["rand", "block-cipher"], optional = true }