summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorIgor Matuszewski <igor@sequoia-pgp.org>2020-06-09 00:44:15 +0200
committerIgor Matuszewski <igor@sequoia-pgp.org>2020-08-13 13:15:05 +0200
commitf07adda6143eec28552c36df6bc31d94e7fc9577 (patch)
tree2bf1a6b6f40954c862e0fa1fcc3007d5b9564419 /openpgp/Cargo.toml
parent033540d9708b0f1de61572bf43212368599d891a (diff)
openpgp: Implement asymmetric key gen/import using Windows CNG API
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index e4faece2..26949d8c 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -51,6 +51,7 @@ unicode-normalization = "= 0.1.9"
[target.'cfg(windows)'.dependencies]
win-crypto-ng = { version = "0.2", features = ["rand"], optional = true }
+num-bigint-dig = { version = "0.6", default-features = false, optional = true }
[build-dependencies]
lalrpop = "0.17"
@@ -68,7 +69,7 @@ rpassword = "=4.0.3"
default = ["compression", "crypto-nettle"]
# TODO(#333): Allow for/implement more backends
crypto-nettle = ["nettle"]
-crypto-cng = ["win-crypto-ng"]
+crypto-cng = ["win-crypto-ng", "num-bigint-dig"]
# The compression algorithms.
compression = ["compression-deflate", "compression-bzip2"]