summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-03-11 09:50:27 +0100
committerJustus Winter <justus@sequoia-pgp.org>2020-03-11 09:50:27 +0100
commit37a76a2c6dbd0720a62d3808500f4b42c2cbb5a8 (patch)
tree110e24d001b4704ccdf76d1eedd4341ae5417da2 /openpgp/Cargo.toml
parente69217dbd91e64b9b4011c95df73f2cdc4581f94 (diff)
openpgp: Only build the padding example if compression is enabled.
- Fixes #448.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 3b7a8eeb..11ce5934 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -55,3 +55,7 @@ compression-bzip2 = ["bzip2", "buffered-reader/compression-bzip2"]
# Vendoring.
vendored = ["vendored-nettle"]
vendored-nettle = ["nettle/vendored"]
+
+[[example]]
+name = "pad"
+required-features = ["compression-deflate"]