summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorIgor Matuszewski <igor@sequoia-pgp.org>2020-06-15 01:25:59 +0200
committerIgor Matuszewski <igor@sequoia-pgp.org>2020-08-13 15:19:57 +0200
commit18b00b17a57f824ad5a872fffffa54ad09444647 (patch)
tree4a98213197a961e6b09370ebc6adb78eac31ce4b /openpgp/Cargo.toml
parente43b18ac4018ff621c6bf0e97788abd232c8b021 (diff)
openpgp: Implement DSA signatures using Windows CNG
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 3d18b208..9e589d0b 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -54,6 +54,7 @@ win-crypto-ng = { version = "0.2", features = ["rand"], optional = true }
num-bigint-dig = { version = "0.6", default-features = false, optional = true }
# rand feature is unnecessarily required, see https://github.com/dalek-cryptography/ed25519-dalek/pull/110
ed25519-dalek = { version = "1.0.0-pre.4", default-features = false, features = ["rand", "u64_backend"], optional = true }
+winapi = { version = "0.3", default-features = false, features = ["bcrypt"], optional = true }
[build-dependencies]
lalrpop = "0.17"
@@ -71,7 +72,7 @@ rpassword = "=4.0.3"
default = ["compression", "crypto-nettle"]
# TODO(#333): Allow for/implement more backends
crypto-nettle = ["nettle"]
-crypto-cng = ["win-crypto-ng", "ed25519-dalek", "num-bigint-dig"]
+crypto-cng = ["winapi", "win-crypto-ng", "ed25519-dalek", "num-bigint-dig"]
# The compression algorithms.
compression = ["compression-deflate", "compression-bzip2"]