summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorNora Widdecke <nora@sequoia-pgp.org>2021-07-26 12:28:29 +0200
committerNora Widdecke <nora@sequoia-pgp.org>2021-12-13 19:01:14 +0100
commit321b0cc381f3c44f81cfc4a9cf502be169262d14 (patch)
tree20c5ee6c7a551872a5037d89331b642e6190f4a8 /openpgp/Cargo.toml
parenta79a35952cb2cf92bd6ba60fa7df057fb2eae1d2 (diff)
ipc, openpgp: Bump quickcheck to 1.0.3.
- Adapt to the new API: - Gen is now a struct, not a Trait, and replaces StdThreadGen. - The rand re-export has been removed. As a consequence, we need our own function to generate an arbitrary value from a range.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 7e8c0e07..29a553b2 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -86,8 +86,9 @@ rand = { version = "0.7", features = ["wasm-bindgen"] }
lalrpop = ">=0.17"
[dev-dependencies]
-quickcheck = { version = "0.9", default-features = false }
-rand = { version = "0.7", default-features = false }
+quickcheck = { version = "1", default-features = false }
+quickcheck_macros = { version = "1", default-features = false }
+rand = { version = "0.8" }
rpassword = "5.0"
criterion = { version = "0.3.4", features = ["html_reports"] }